1. trevorcpa's Avatar
    I installed the new EH03 update from Verizon last night. Google Maps Navigation locked up on me at first, but worked after a battery-pull. My main issue after the update is that I cannot get the GPS to lock no matter how long I give it. It was working before the update, but now, nada. I hope they'll follow up with a patch to fix the various bugs in EH03.

    12-02-2011 03:48 PM
  2. xeroslash's Avatar
    I've noticed no bugs since updating yesterday. In fact, my GPS works incredibly fast with the update whereas with Froyo it had the 'didn't lock no matter long' symptom.

    Loving this update. Sorry to hear you're having issues. On Froyo, a battery pull always (temporarily) fixed my GPS issue.
    12-02-2011 05:38 PM
  3. spillytime's Avatar
    My GPS doesn't lock on at all either. And sometimes my phone just makes the sound like it is booting and has a black screen. i have to battery pull after it.
    12-02-2011 11:48 PM
  4. SmarterJP's Avatar
    My GPS stopped working after the OTA update to Gingerbread. I've tried everything I could find to resolve this but nothing is working. I may just end up going back to stock and updating up until FroYo and leaving it there. FroYo was working excellently for me and so far Gingerbread brought me nothing but stress. No GPS and my battery life has dropped.
    12-03-2011 11:54 AM
  5. johnsma22's Avatar
    FWIW, to you guys still doing the battery pull to recover from a locked up phone, there is a better way that will prevent anything bad, like corrupting the memory, from happening to your phone. You simply hold the volume up and power buttons simultaneously for about ten seconds. This will reboot your phone no matter how stuck it gets.
    ctuffy likes this.
    12-03-2011 12:05 PM
  6. johnsma22's Avatar
    Also, I couldn't get a gps lock either after flashing EH03 Superclean. After going into "Location & Security" in the settings, I clicked off "VZW location services" and "Google location services" and then enabled "Standalone GPS services" I got a gps lock in about 10 seconds!
    12-03-2011 12:08 PM
  7. r1200gsrider's Avatar
    I couldnt get the GPS to lock I called verizon the said that I need to do a hard reset after I update to Gingerbread. so I am reflashing back to stock and starting over I will let you know if this works.
    12-03-2011 03:44 PM
  8. _CJ_'s Avatar
    No lock at all here either . Hopefully theres a fix soon.
    12-04-2011 01:44 PM
  9. johnsma22's Avatar
    Uncheck all location services and then check only gps and see if that helps. It did for me.
    12-04-2011 05:54 PM
  10. fatalpuls3's Avatar
    No such luck Johnsma22. Thanks for the suggestion. im unsure m goign to continue to rely on this phone for gps when gps only costs 100 bucks to get one that just works ALL the time no reliability issues.
    12-05-2011 07:51 AM
  11. r1200gsrider's Avatar
    Ok I got my GPS to work I flashed my phone with CI500_VZW_DL09_ECLAIR.tar.md5 and then did all the OTA updates and now my GPS Locks right away.
    12-05-2011 05:10 PM
  12. fatalpuls3's Avatar
    Heres the fix guys thanks to someone at the vzw forums:
    I had to do this one because i performed a factory reset on my phone and it broke and stopped at the E3 recovery, no there was no root or anything it was purely stock prior to factory reset. soo i knew how to do this odin process and i grabbed the files and viola looks like its working now, the symbol shows, no lock ups, ill perform complete test tomorrow morning on the way to work and post when i get there. hope this helps guys

    12-06-2011 10:04 AM

    For those of you with problems with your Fascinate GPS that can't get a fix and nothing seems to work, I had that issue as well. Although I was able to use Google Maps and Navigation, GPS signals could not be found. In fact, the "gps search" icon that used to appear in the notification bar never appeared and third party "gps status" apps could not find any GPS satellites. It was as if my phone was unable to initiate the GPS function. I decided that I needed to reinstall Gingerbread and by doing so, completely wipe my phone by putting a clean Verizon stock build of Gingerbread on my Fascinate.

    After following the steps below, your Fascinate's software will be the same as when the phone was new and you were starting it for the first time, only now the Android OS will be Gingerbread.

    WARNING: If you follow the steps below, ALL of your settings and saved files on your phone (but not on your SD card) will be erased. Remember to back up contacts, bookmarks, SMS messages, and whatever else you think you'll want before installing Gingerbread using these methods.

    Step 1: Download and install Samsung Fascinate USB drivers Samsung (Select "Software" and click the file icon to download the driver)

    Step 2: Download Odin, a computer program you will use to install Gingerbread. Odin3 v1.83.exe

    Step 3: Download Verizon Fascinate Gingerbread stock build, EH03: Multiupload.com - upload your files to multiple file hosting sites!

    Step 4: Power off phone and pull battery.

    Step 5: Plug in factory usb cable to your computer and the phone while pressing the phone's volume down button. A yellow triangle will appear on the phone with a message saying "download mode". Release the volume button.
    Step 6: Run odin on your computer.

    Step 7: Click on button labelled "PDA" in odin and select the EH03 Gingerbread file you downloaded to your computer in step 3.

    Step 8: Click start and wait about 10 minutes. The box in the left hand corner of odin will say PASS, then click reset.

    Step 10: Unplug usb cable, put battery back in and turn on phone.

    After initially setting up your phone, you can relatively easily reinstall all of your Android apps, go to http://market.android.com, login and select the "My Library" tab to view all of the apps you have ever downloaded to your phone. Using the website, you can install the apps you want and they will be sent to your phone and installed automatically.
    SmarterJP, z2z and Jonnysells like this.
    12-07-2011 07:29 PM
  13. SmarterJP's Avatar
    Thanks so much, fatalpuls3, I followed what you had posted and I am finally up and running properly on GB with my GPS finally working. It is blazing quick and even indoors locks within seconds. What a relief!
    12-08-2011 12:24 AM
  14. z2z's Avatar
    Thank you sooooooo much! I had gps problem but now it's gone. GPS works perfectly and locks really fast, even in door! Thanks again!
    12-08-2011 06:07 PM
  15. Jonnysells's Avatar
    Thanks fatalpuls3 - nice work; so far so good. I was locked on the nav beta screen any time I tried to get directions and or map view. I uninstalled and reinstalled multiple times to no avail... Followed fatalpuls3 directions and viola. It worked the first time right away!... not sure if I did it correctly or not however because all of my settings and apps were untouched.
    02-12-2012 01:26 PM
  16. cjr4497's Avatar
    the link in step 3 is not working. it there another place to download stock EHO3
    03-07-2012 08:26 PM
  17. sushiguy732's Avatar
    the link in step 3 is not working. it there another place to download stock EHO3
    You can go to this LINK to download all version of the stock files.

    The reason step 3 is not working is because they were probably published on Megadownloads (or similar) which have all gotten shut down.

    BTW... This is my 600th post! YAY ME!!!
    03-08-2012 09:01 AM
  18. cjr4497's Avatar
    Well, it didn't fix my gps but my battery life is back to normal. I had excellent battery life before the update and now it is back.

    Sent from my SCH-I500 using Tapatalk
    03-10-2012 08:45 AM
  19. cjr4497's Avatar
    well, come to find out the gps does work now, only very poorly. It works on clear nights and that is it. I got it to catch a little on a cloudless day, it would work for a few minutes then go out. that only lasted for a couple of hours.
    04-10-2012 05:30 PM