1. rkohlin's Avatar
    Wifi on my sch-i545 always worked fine, & esp better after the ng6 update (which I put off for weeks, reading the boards to make sure it was ok before I allowed the*OTA*update). I was glad it didn't do some awful things to mine that it evidently did to a few other models...

    Then I accidentally allowed the nk1 update OTA* on xmas eve.
    Arrrggghhh!

    Nothing but problems since!
    I seem to have very strong wifi signal, but my phone constantly drops/reconnects, and I cannot connect to internet sites at all. (Have to use mobile network, which would be ok, but I find that at a certain point, Verizon cuts me off, "internet has stopped" & the tab/page/crashes. Not acceptable.

    Have tried so many things, (xcpt reset - that is not an option nor answer (altho the helpful folks at Verizon have no other answer), besides, I've read of many people doing this, & it doesn't make a diff, just costs hours of time/effort for the same result).

    I've even tried setting my router to static channels (vs auto) - I'm convinced it's the dang phone (s/w), not the router - all was more than fine till this last nk1 4.4.2 update. Arrrgh!

    Anyone know a way I can revert to the most previous ng6 update?!!

    I've been hunting on the boards -*
    Only found dirs for rooted phones - I really don't want to root my phone...

    Hope someone can help!
    01-03-2015 02:26 PM
  2. Rukbat's Avatar
    Check your router (use a browser on a PC that connects). Look at the wifi security setting. If the encryption is TKIP or TKIP+AES, change it to AES. KitKat seems to be having a problem with TKIP.

    If that still doesn't solve it, buy a Netgear N300 router (from some place that has a liberal return policy, just in case that doesn't fix it) and set that up as your router. My expensive Linksys doesn't work right (even with AES encryption) with KitKat. The cheap (US$35) Netgear works fine. I don't know if 4.4.4 or 5 fixes the problem, but it's going to be a long time before I allow an OTA. My 4.4.2 phone works. I don't need all new bells and whistles that make it not work.
    rkohlin likes this.
    01-03-2015 03:17 PM
  3. rkohlin's Avatar
    Thanks for the reply, Rukbat!
    Yes, my fairly new (April '14) ASUS router is set to AES on both 2.4 & 5 Ghz. I got this router as I scoured the boards earlier last year for one that worked well with the galaxy s4, as I had probs with my prev linksys router -
    Some folks were saying both linksys (my prev) and netgear did not work well with the s4, but highly recommended the ASUS RT-N66U, which is what I've had since April.
    I had no wifi issues till this last update - arghh!

    Guess I'll keep searching for solutions...
    01-05-2015 06:39 PM
  4. THEPRFCT10's Avatar
    I've had same exact annoying problems since and only after nk1 update. Prior to I was very pleased not to mention my battery life has sucked since the update with no practice changes on my part. Hoping lollipop changes this. Not holding my breath.
    01-06-2015 09:02 PM

Similar Threads

  1. Help needed after update to Lollipop
    By N_Face in forum LG G3
    Replies: 9
    Last Post: 01-04-2015, 06:15 PM
  2. Replies: 1
    Last Post: 01-04-2015, 03:33 PM
  3. Lg G3 lollipop update messed up internal memory
    By N_Face in forum Ask a Question
    Replies: 2
    Last Post: 01-03-2015, 11:32 PM
  4. Don't have 4G after Lollipop update
    By HoLfElDeR in forum Moto X (2014)
    Replies: 3
    Last Post: 01-03-2015, 05:22 PM
  5. Another Update Fails
    By sparker781 in forum AT&T Samsung Galaxy S4
    Replies: 0
    Last Post: 01-03-2015, 01:38 PM
LINK TO POST COPIED TO CLIPBOARD