1. Khatru's Avatar
    First post, so first off: Greetings!

    So! I bought the Razr M a couple of weeks ago, just prior to the JB update. Had no issues with the phone prior. After the update, however, I ran into a few problems:

    1. External Storage doesn't seem to be read properly. My Pictures folder on my card is populated with 96 pictures, although the Gallery app only displays 50 (but I can still view the other 46 pictures in the files browser). Also, I'm unable to assign any ringtones directly from my SD card in Sound settings. Yet when copied to internal storage, the phone will display my ringtones in Sound settings and allow me to assign them.
    2. I have not been able to select "USB mass storage" for the USB connection settings since the update. Has this feature been omitted?
    3. Though this isn't an issue, per se, I've noticed that the sound effects and equalizer in the Sound settings are no longer available since the update. I'm content without them, but was just wondering if they are suppose to still show up in 4.1.

    Bear in mind that I have done a factory reset, as well as reformatted my microSD card, and these problems continue to persist. The only issue the factory reset fixed was with my smart actions (they would not save any alterations I made to the triggers nor actions).

    I'm still under the store's return policy, and I'm strongly considering doing an even exchange. Although, if they have extended their deal on the SIII, I MAY just swap the M for it. Anyone keen on a fix? Or does anyone know what is causing these problems? And any opinions on swapping out my M for an SIII are appreciated as well.
    11-25-2012 02:25 PM
  2. j.s.castle's Avatar
    I've had a problem with connecting to my linux computer (seem that only windows and mac software is included surprising since android is linux based ) but mass connecting has been deleted. Tech support told me to use developer options USB debugging but so far that hasn't worked so I've been removing the SD card and writing directly to that. Also sleep mode has been deleted however airplane mode is nearly as effective at saving the battery. Those are the only problems I've had.
    DeputyBob likes this.
    11-26-2012 02:20 PM
  3. Khatru's Avatar
    Well, now the phone simply won't pick up anything on the card in Gallery nor in Play Music apps. The content is on the card, and viewable/capable of being played when accessed from External Storage in the Storage settings. I chatted online with tech support also, who told me to call since I've already run through troubleshooting. For now, any content I load onto the card has to be done via a USB card reader. Why would they rescind mass storage connectivity? Argh!

    I love this phone, but if the issues I'm coming across are not a direct result of this unit simply being a lemon, I'll have to bite the bullet and just go with the SIII to spare myself the hassle.
    11-27-2012 02:31 AM
  4. iterlegis's Avatar
    I just received a Razr M through work and had the same issue. Before updating to Jellybean, mass storage was available... after, no.

    I don't have any concrete answers, but googling- it seems that mass storage was disabled because people were sideloading software content Verizon didn't like.

    Thus the much more locked down (and PITA) Media protocol.

    Hopefully, this isn't the case and a fix / update / work around / etc. will arise soon.
    11-29-2012 09:52 AM
  5. bjmh46's Avatar
    Very similar, and probably related problem here:
    If I use ESfile explorer to transfer pics from one of my computers (via wifi) to the sd card on my phone, I can view the pics on the phone through ES, or the native file explorer, but not thru Gallery--that is until I reboot the phone, then all is well. This was not the case with ICS, only happened after Jellybean OTA update. All in all, I think we need another update to fix the few little glitches JB gave us. IMHO, there was a rush to get JB out before the end of the year, and it was not quite ready for primetime.

    12-03-2012 06:02 AM
  6. zarguy's Avatar
    I just got off the phone with Moto 2nd level tech support. USB Mass Storage has been removed from Jelly Bean. Tried enabling USB Debugging to no avail. I've seen post saying that they cab get USB Mass Storage to work, but not me. I'm not rooted.

    12-03-2012 06:18 PM
  7. Ry's Avatar
    Also, I'm unable to assign any ringtones directly from my SD card in Sound settings. Yet when copied to internal storage, the phone will display my ringtones in Sound settings and allow me to assign them.
    Where were they store on your SD card?
    12-03-2012 06:27 PM
  8. zarguy's Avatar
    I found an app called Airdroid that lets you mount your phone's sd card on your computer via wifi to a website. so far, so good.
    12-03-2012 06:42 PM
  9. Khatru's Avatar
    Where were they store on your SD card?
    They were in the Ringtones folder. I copied all the directories from internal storage over to the SD card verbatim, and then put my files in them.

    UPDATE: I found some workarounds. I also contacted Motorola support, and even their level 2 tech guy was like "lolwut?". It turns out this is pretty common with the 4.1 update, particularly with the M and the Nexus S.

    Getting around the directory problem: For the issue with Gallery not pulling up everything (or in some cases, nothing), you can use the QuickPic app. It's pretty user friendly, and will detect everything.

    When it comes to Google Play, I noticed that a lot of users also could not get their library to show up; their fix was to download an app as well. I learned - however - that if you rename the "Music" folder to "Audio", then the Google Play app library will detect your music. Also, putting the Ringtones and Notifications folders in said Audio folder allowed for the phone's sound settings to suddenly pick up my ringtones (I haven't put anything back in the Notifications folder yet).

    I hope this helps others with identical/similar issues. Motorola tech guy said he'd call me back this Saturday as a courtesy follow up; I'd like to see if he has any experience with the aforementioned problems by now, and if so, maybe he can inform me of a patch. =D
    12-06-2012 06:31 PM

Similar Threads

  1. Replies: 12
    Last Post: 04-17-2013, 04:22 AM
  2. Droid Razr Maxx Text Message Problem
    By abhinavprasad in forum Droid RAZR MAXX
    Replies: 2
    Last Post: 06-03-2012, 09:42 AM
  3. Problem with messaging on Razr
    By roachman55 in forum Droid RAZR
    Replies: 0
    Last Post: 03-05-2012, 08:38 AM
  4. Razr Maxx, Motorola or Droid Problem?
    By crs96 in forum Droid RAZR MAXX
    Replies: 6
    Last Post: 02-08-2012, 07:07 PM
  5. Need some help with Razr problems- switched from Gnex
    By JoshH37#WN in forum Droid RAZR
    Replies: 25
    Last Post: 12-29-2011, 05:31 PM