1. rocker22dallas's Avatar
    my phone is currently running calk's stock 4.0.3 with FC05 modem
    i want to run [ ROM ] Calkulin's E4GT 2 v1.1 [ ICS l FC07 l Tweaked l Battery Saver Script ]

    the current os i am running has no CWM.
    i cannot find a .tar file to flash that would be a simple update.
    the CWM for FC06 (link) says not to flash any rom from that recovery
    i don't want to brick my phone.

    the reason i want to upgrade to calk's new rom is that i really want the hotspot hack, and have been enjoying ics.

    i also plan on updating to fc07, but do not want to until i examine my options. i kind of jumped the gun on my current operating system, and wish i would have waited a week until the one i want came out :P

    any help is greatly appreciated. i saw a lot of questions about this in the thread, but saw no answers.
    03-12-2012 10:39 PM
  2. JayWill's Avatar
    1) Make any App backups you want in TB

    2) Odin back to EL29 with this [ODIN][TAR] SPH-D710.EL29_CL852097 (EL29 Modem/Kernel/ROM - Full Restore - Rooted) - xda-developers

    3) Use the autoroot tool to install the EL29 kernel + CWM repack [ROOT][NCIQ][EG30/EG31/EK02] Auto root your existing stock ROM (w/o ODIN/ROM Flash) - xda-developers

    Phone will reboot after installing the kernel (sfhub's tool does this for you)

    4) Shut down and boot into CWM.

    5) Flash Calkulin's Format All ZIP

    6) Flash Calkulin's ROM and the Modem (in the same CWM session)

    7) Reboot and enjoy

    This is the safest method right now until the ICS kernel + CWM issue gets resolved.
    rocker22dallas likes this.
    03-12-2012 10:53 PM
  3. rocker22dallas's Avatar
    Thanks very much! I thought that may be the way, just wasn't sure if it was safe to downgrade the software. Is it safe to roll back to older modems as well?

    Sent from my Galaxy S II epic 4g touch. 4.0.3 FC05 ICS on tapatalk
    03-13-2012 07:07 AM
  4. JayWill's Avatar
    Thanks very much! I thought that may be the way, just wasn't sure if it was safe to downgrade the software. Is it safe to roll back to older modems as well?

    Sent from my Galaxy S II epic 4g touch. 4.0.3 FC05 ICS on tapatalk
    Absolutely safe. You can actually use any modem you want with any build version. So for an extreme example, you can be running the EG30 modem (technically the first) with the latest FC07 ICS ROM and kernel.

    Sent from my E4GT via Tapatalk
    03-13-2012 12:19 PM
  5. VDub2174's Avatar
    1) Make any App backups you want in TB

    2) Odin back to EL29 with this [ODIN][TAR] SPH-D710.EL29_CL852097 (EL29 Modem/Kernel/ROM - Full Restore - Rooted) - xda-developers

    3) Use the autoroot tool to install the EL29 kernel + CWM repack [ROOT][NCIQ][EG30/EG31/EK02] Auto root your existing stock ROM (w/o ODIN/ROM Flash) - xda-developers
    Using this saved me when I flashed an ICS ROM that didn't have CWM available yet. As with the OG Epic 4G, ODIN is a life saver!!
    03-15-2012 12:00 PM
LINK TO POST COPIED TO CLIPBOARD