07-09-2014 11:45 AM
426 ... 45678 ...
  1. brandonabandon's Avatar
    scroll the forums-loki, lg viper, etc. i recall seeing an aboot discussion a few months back. i think the zvi aboot img could be readily available. maybe try loki github as well. so cm9 was a also a fail, but during the modding to process to build, i may have found the reason cm10 was not building. i.e. im trying cm10 once more. good luck with unlocking the bootloader ed.
    12-02-2013 10:49 AM
  2. brandonabandon's Avatar
    root.c error: to many arguments in function make_ext4.h. Occurs while insyalling cot after boot.img processes. Any suggestions? Weird, got the same error with cm10 (charger.o) a workaround exists, now this error...looking into 10.1 soon.
    12-02-2013 02:36 PM
  3. Edward McInnish's Avatar
    the 0rigina| s0urce c0ntains a |0t 0f inf0rmati0n ab0ut things that d0 n0t w0rk with the viper
    it is p0ssib|e that is 0ne 0f them maybe?
    as f0r that tread, i saw it 0nce but iirc, n0 0ne figured it 0ut
    i wi|| |00k again t0 be sure

    0nce again i want t0 ap0|0gize ab0ut ta|king in |33t Its hard t0 type at a|| when y0ur | and 0 butt0ns arnt w0rking making y0u use the equivi|ant
    Its an even bigger pain when this is the 0n|y pc i have that has w0rking usb p0rts and even they are iffy at best
    Own3r likes this.
    12-02-2013 07:51 PM
  4. brandonabandon's Avatar
    The workaround the make_ext4 error in root.c is to remove the extra variables i read. Can someone explain this procedure?
    12-03-2013 03:52 PM
  5. brandonabandon's Avatar
    I repo'd cm10.1 over cm9 and synced. Git branch *default? Android/.repo/repo/.git . Why not cm10.1?
    12-04-2013 02:46 PM
  6. brandonabandon's Avatar
    https://github.com/djrbliss/loki/pull/3 this might be the aboot ed. https://www.dropbox.com/s/6gxz7q0kci7r04s/LS840.rar
    12-04-2013 04:35 PM
  7. thenameisnigel's Avatar
    I repo'd cm10.1 over cm9 and synced. Git branch *default? Android/.repo/repo/.git . Why not cm10.1?
    Bad idea. Always use separate directories for different versions. There's a lot of things that changed dramatically from CM9 to CM10.1.

    Posted via Android Central App
    12-05-2013 05:04 AM
  8. brandonabandon's Avatar
    cm - Pastebin.com cm10.1 build error. ive tried installing dif java and dif qcom/hardware where the .h file exists. no search results. tried make clobber and build from scratch, same error. running make -j4 bacon. any ideas?
    12-09-2013 01:46 AM
  9. brandonabandon's Avatar
    cm - Pastebin.com error with make bacon, no -j4. libmedia not writing out. can i resolve this?

    Add IMPLEMENT_META_INTERFACE( your_service_class) <---found this, not sure how or where to execute. any ideas?
    12-09-2013 11:39 AM
  10. brandonabandon's Avatar
    not sure if the last error resolved. been running make -j2 bacon, got the same error, repo sync. ran make -j2 bacon again, new error
    hardware/qcom/display/libgralloc/fb_priv.h:48:26: error: field 'fence' has incomplete type
    hardware/qcom/display/libgralloc/fb_priv.h:49:31: error: field 'commit' has incomplete type
    Building Cm 10.1 (4.2.2) - LG Optimus Sol Nightly/Experimental - CyanogenMod Forum
    link above has solution but the link to the solution is broken. im running makes with different display folders, legacy not working. any ideas?
    12-10-2013 05:46 PM
  11. brandonabandon's Avatar
    w/legacy - Pastebin.com <--thunk error with libmedia.so. this is a rerun from a 3-4 hour build. deleted qcom folder, resync, add legacy folders was my process. any ideas?
    12-11-2013 09:34 AM
  12. brandonabandon's Avatar
    According to the link i need to do declare the scope under linux. Help with that anyone?
    12-11-2013 05:43 PM
  13. brandonabandon's Avatar
    oem - Pastebin.com <--oem problem now. help
    12-12-2013 03:20 PM
  14. brandonabandon's Avatar
    omx - Pastebin.com <-- omx error. help, how to fix headers? later that build-->omx 2 - Pastebin.com. help
    12-12-2013 03:57 PM
  15. brandonabandon's Avatar
    The vdec errors are due to the random 1080 any ideas
    12-14-2013 03:28 PM
  16. brandonabandon's Avatar
    the 1080 built. got new error at compileing. sound/builtin.o in function `get_page`, blahblah Linux/mm.h;397: more undefined references to `__get_page_tail` follow. then ***make .tmp_vmlinux1 error 1. on it.
    12-16-2013 04:53 PM
  17. brandonabandon's Avatar
    Lol https://blu168.afx.ms/att/GetAttachm...058&oneredir=1. sorry crazy link. Mobile upload. Shuffling the files about between iproj and nigel kernel sources, i got a ramdisk.img. Nigels kernel will build all drivers besides sub.o in relation with the required 1080p.fw to build cm10.1. The iproj will pick up the sub.o but errors at quite a few other drivers. Shuffleing the linux folders between builds' got the ramdisk.img built. the new error with abc looks tough. another error i will upload next post has also been tough. paying a visit irc. Any ideas?
    The link not working? Here is the problem with my build, Main.cpp:123: error: Undefined reference to 'bcc::abccompilerdriver

    Main.cpp:201: error: undefined reference to 'bcc::init::initialize'
    12-18-2013 02:16 PM
  18. brandonabandon's Avatar
    links not working. Copy paste this. Error relation with mp4utils.o omxvdec_intermediates. Msm_ion.h 27.6: error: multiple definition of 'enum ion_heap_ids' and ion.h ION-HEAP_TYPE_IOMMU previous declaration error. I can post the actual builds later if necessary.
    12-18-2013 02:36 PM
  19. brandonabandon's Avatar
    Got the zimage and recovery.img. the libmedia.so error from before has returned! Aghh! Help lol. Android to virtual thunk..hmmm.
    12-21-2013 03:23 PM
  20. brandonabandon's Avatar
    flash the kernel to stock?
    12-23-2013 05:32 AM
  21. brandonabandon's Avatar
    makewarnings - Pastebin.com kernel compiles. same error compiling libmedia.so. maybe related to the warnings when i start the build? tried different versions of java also. any advice?
    12-28-2013 08:26 AM
  22. brandonabandon's Avatar
    Different machine, new project. the cm-10.1 project shall remain on stand-by, the libmedia.so error has yet to be resolved. On my dell, new hd/memory upgrade. Beginning new project with cm9.will cot build ics? No mention of the branch. Any advice?
    12-30-2013 09:24 AM
  23. brandonabandon's Avatar
    Between work, the lousy internet connection of my public library and the network adapter my laptop needs in order to not freeze, and this new problem with repo im experiencing on my new build machine http://forums.androidcentral.com/gen...c-problem.html, this may take a while. Going through each file one at a time with -j1, grueling.
    01-02-2014 12:47 PM
  24. brandonabandon's Avatar
    Repo is not d'ling some files completely. Anyway to resolve this?
    01-02-2014 02:37 PM
  25. brandonabandon's Avatar
    Oops got a 32bit ubuntu installed.lol. After reinstalling and programming ubuntu i will copy/paste the entire .repo/projects folder to my new build machine since repo init is being stingy and i will post the results
    01-03-2014 06:42 PM
426 ... 45678 ...

Similar Threads

  1. LG G2 vs the note 3
    By ab304945 in forum Sprint LG G2
    Replies: 14
    Last Post: 11-13-2013, 09:38 AM
  2. LG Keyboard crashes?
    By Ken7 in forum LG G2
    Replies: 8
    Last Post: 09-25-2013, 01:17 PM
  3. Restore stock rom..
    By 10rdan in forum HTC One X
    Replies: 7
    Last Post: 09-22-2013, 10:13 AM
  4. Losing my mobile signal flashing any T-MO Rom on my T999V GS3
    By Nemesis-X in forum T-Mobile Galaxy S III
    Replies: 2
    Last Post: 09-21-2013, 06:57 AM
  5. LG Optimus F3 displaying incorrect time.
    By zargontapel in forum LG Optimus Series
    Replies: 6
    Last Post: 09-20-2013, 06:22 PM