1. Gmanmonster's Avatar
    My brand new Turbo 2 was not impressing me, my 2013 Moto X (which was given to my daughter) was outperforming it. I tried to disable a bunch of apps and restarted a few times a day, but did not make much of a difference. I was about to do a factory reset, but dreaded the rebuild.

    So, I deleted my google account, restarted the phone and re-installed my google account. I don't know why it made such a difference, but it did. The phone flies now. All the apps just zoom.

    Give it a shot
    Michael
    01-25-2016 09:02 AM
  2. SpookDroid's Avatar
    Might have been a sync glitch. Weird. But glad to see it helped! One more thing to try before the dreaded factory reset! Thanks for the tip!
    01-25-2016 12:04 PM
  3. THEPRFCT10's Avatar
    Can you list the exact steps as to how you deleted your account please?
    01-25-2016 01:21 PM
  4. Gmanmonster's Avatar
    Settings - Accounts - Google - click on the email account you want to delete, it will take you to the sync page. Click 3 dots in upper right corner - select remove account. Answer "continue" to questions

    I restarted my phone after the removal, then re-added the same account. I am guessing that Spookdroid was right and some syncing glitch was bogging down my phone.
    01-25-2016 02:14 PM
  5. Edward Llamas's Avatar
    My brand new Turbo 2 was not impressing me, my 2013 Moto X (which was given to my daughter) was outperforming it. I tried to disable a bunch of apps and restarted a few times a day, but did not make much of a difference. I was about to do a factory reset, but dreaded the rebuild.

    So, I deleted my google account, restarted the phone and re-installed my google account. I don't know why it made such a difference, but it did. The phone flies now. All the apps just zoom.

    Give it a shot
    Michael
    05-05-2016 08:34 PM
  6. Snareman's Avatar
    Was your phone slow with everything? This phone has the most hideous lag of any recent phone I've had.
    05-08-2016 11:04 PM
  7. ChuckLIII's Avatar
    I have never experienced any lag at all with the Turbo 2.
    05-11-2016 08:01 AM

Similar Threads

  1. Replies: 7
    Last Post: 03-05-2016, 05:11 AM
  2. Why did my phone screen turn black?
    By AC Question in forum Samsung Galaxy S6 active
    Replies: 1
    Last Post: 01-25-2016, 08:14 PM
  3. Is the star icon on my toolbar of my mobile phone safe?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 01-25-2016, 07:58 AM
  4. How do I remove the four digit pin number to unlock my phone?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 01-25-2016, 06:58 AM
  5. I can't remove virus from my phone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-25-2016, 06:44 AM
LINK TO POST COPIED TO CLIPBOARD