05-03-2019 01:43 PM
60 123
tools
  1. TechNut79's Avatar
    Recently I've noticed that when updating apps, they download horribly slow. Like they will almost fully download and then hang just at the end. I've tried clearing data and cache + force closing the Google Play store and I've uninstalled updates. I've also done the same to the Download Manager. My router's firmware was just updated and it was rebooted 2 or 3 times. Anything else that I can try?
    ryguardiano likes this.
    04-25-2019 06:49 PM
  2. mustang7757's Avatar
    Recently I've noticed that when updating apps, they download horribly slow. Like they will almost fully download and then hang just at the end. I've tried clearing data and cache + force closing the Google Play store and I've uninstalled updates. I've also done the same to the Download Manager. My router's firmware was just updated and it was rebooted 2 or 3 times. Anything else that I can try?
    Have you tried with data only no wifi?
    04-25-2019 07:17 PM
  3. TechNut79's Avatar
    Have you tried with data only no wifi?
    I haven't, but I don't have unlimited data, so I'm not sure I'll give this a try unless it's a small file size.
    04-25-2019 07:21 PM
  4. mustang7757's Avatar
    I haven't, but I don't have unlimited data, so I'm not sure I'll give this a try unless it's a small file size.
    Try just one if it goes fast most likely something up with the wifi
    04-25-2019 07:32 PM
  5. TechNut79's Avatar
    Try just one if it goes fast most likely something up with the wifi
    I will, but I doubt it's the wifi as all other devices are experiencing no hiccups whatsoever.
    04-25-2019 07:35 PM
  6. mustang7757's Avatar
    I will, but I doubt it's the wifi as all other devices are experiencing no hiccups whatsoever.
    Just try one download , let me know how it goes.
    TechNut79 likes this.
    04-25-2019 07:52 PM
  7. TechNut79's Avatar
    Nope, does almost the same thing on data. With data it downloads all the way and still sits there awhile before installing. On WiFi, it gets almost fully downloaded and stops, then eventually finishes and installs. I'm not sure what to think.
    04-25-2019 09:17 PM
  8. TX Jedi's Avatar
    I'm having the same problem. The last two days (WiFi) and my WiFi is working fine.
    04-25-2019 09:18 PM
  9. TechNut79's Avatar
    I wish mine was just the last two days.
    mustang7757 likes this.
    04-25-2019 09:19 PM
  10. mustang7757's Avatar
    I wish mine was just the last two days.
    Have you tried clearing cache and force stopping Google play services?
    04-25-2019 09:50 PM
  11. TechNut79's Avatar
    That I have not tried. Doing it now.

    I couldn't force stop, it was grayed out. I did clear cache though.
    04-25-2019 09:52 PM
  12. mustang7757's Avatar
    That I have not tried. Doing it now.

    I couldn't force stop, it was grayed out. I did clear cache though.
    Ok..let's see what it does..
    04-25-2019 09:54 PM
  13. mustang7757's Avatar
    Ok..let's see what it does..
    Uninstall the update
    04-25-2019 09:55 PM
  14. TechNut79's Avatar
    Already did that earlier today. You mean for Google Play?
    04-25-2019 09:57 PM
  15. mustang7757's Avatar
    Already did that earlier today.
    No for play services
    TechNut79 likes this.
    04-25-2019 09:57 PM
  16. TechNut79's Avatar
    It says it was unsuccessful. I've had trouble with that in the past.
    04-25-2019 09:59 PM
  17. mustang7757's Avatar
    It says it was unsuccessful. I've had trouble with that in the past.
    Very strange
    04-25-2019 10:00 PM
  18. mustang7757's Avatar
    Looks like a problem with play store not your connections
    04-25-2019 10:01 PM
  19. TechNut79's Avatar
    Hmm. I think I have the latest version.
    04-25-2019 10:03 PM
  20. mustang7757's Avatar
    do you have any power saving modes on ? or did you restrict playstore from running in background to save battery consumption?
    04-25-2019 10:03 PM
  21. Mike Dee's Avatar
    do you have any power saving modes on ? or did you restrict playstore from running in background to save battery consumption?
    Sounds like its having trouble in the foreground.
    04-25-2019 11:31 PM
  22. mustang7757's Avatar
    Sounds like its having trouble in the foreground.
    Certainly is .
    04-25-2019 11:37 PM
  23. Hghlndr's Avatar
    I traverse this forum though I have a note 8... d:^) Having this same issue. I don't use wifi, and forced stopped, cleared cache etc and when i noticed it happens over many days and different states I simply relaxed saying: ah Google servers. peace
    04-26-2019 12:01 AM
  24. pizza_pablo's Avatar
    I would try SETTINGS - APPS - SYSTEM APPS - GOOGLE PLAY SERVICES - STORAGE - MANAGE STORAGE - CLEAR ALL DATA and reboot.
    TechNut79 and slim6596 like this.
    04-26-2019 12:05 AM
  25. TechNut79's Avatar
    do you have any power saving modes on ? or did you restrict playstore from running in background to save battery consumption?
    I don't believe so.
    04-26-2019 08:09 AM
60 123

Similar Threads

  1. Gallery says need to sign in to google+ fix?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-26-2019, 11:40 PM
  2. Galaxy s10's plus is turning on the screen during calls, resulting in face button pressing
    By Android Central Question in forum Samsung Galaxy S10 & S10+
    Replies: 11
    Last Post: 04-26-2019, 12:24 PM
  3. ((Samsung Galaxy 9+) Copy to clipboard delayed in Samsung Notes only
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 04-26-2019, 05:48 AM
  4. Replies: 0
    Last Post: 04-25-2019, 04:19 PM
  5. Replies: 0
    Last Post: 04-25-2019, 03:37 PM
LINK TO POST COPIED TO CLIPBOARD