06-04-2018 08:43 PM
308 ... 111213
tools
  1. zafar ali2's Avatar
    Dear..i have a strange problem...i m using s4 i9515..wifi works perfectly but hotspot cant enable...whats the solution..? Kindly rep
    12-27-2016 02:49 AM
  2. Cp Divers's Avatar
    So I had the same issue, I did not read everything single post here but here is my solution.

    1 shutdown your phone

    2 boot you phone in system recovery mode, to do so press the power and volume up button together until you see at the very top right corner a tiny blue line, then release the 2 buttons

    3 with the volume down button go to "wipe cache partition", this will NOT delete any data on your phone !

    4 select that option with the power button

    5 reboot your phone with the first option of the menu "reboot system now"

    It worked for me right away

    Hope it helps, good luck to you
    01-09-2017 09:46 AM
  3. dnlabr's Avatar
    I tried all the options that you can think of! I could not make it work! The interesting thing to me is that when I put Dirty Unicorn rom, wifi works....but i want stock rom...
    02-20-2017 02:21 PM
  4. luckysoul777's Avatar
    My S4 won't let me turn on Wi-Fi. I have tried every suggestions in this thread EXCEPT taking it apart to replace antenna and check for loose connection. Eventually I burned a Nandroid backup and flashed the stock ROM. It revives the Wi-Fi! Thus, I'm not sure if it is really related to stock vs. custom ROM as others have suggested. It's more like corrupted vs clean ROM. My OS is obviously corrupted. To prove the point, I restored my Nandroid copy and the problem returned. Since installing a clean copy of the OS and then re-installing/ configuring my 100+ app is too much pain, I am going to live without Wi-Fi. After all I have unlimited data plan with my carrier. I know backing up apps with Titanium backup and then restore can ease the pain, but my experience with TB hasn't been good in the past. Many apps just don't get restored properly.

    If someone can suggest other system files to tweak other than those already mentioned, please post. Thanks
    03-04-2018 06:17 PM
  5. luckysoul777's Avatar
    [update: A few hours later....
    Others have mentioned if I delete this particular file under /data/misc/wifi, it will get regenerated. Well, it didn't on my phone. So I thought if I re-flash with a clean stock ROM, copy all files from this directory, then restore my Nandroid copy and then replace this directory with these clean files, it may fix the problem. After I re-flashed with a clean ROM, the WiFi still wouldn't turn on, but it did earlier! WTF!!!...

    After checking under "About device", I noticed the baseband was from a different rev, I337MVLSGQB1, than the ROM I just re-flashed, I337MVLUGOH1. So Odin skip the baseband if the code on the device is newer? I then extracted the baseband, modem.bin, from the -OH1 ROM, and burned this file directly. Guess what? By having the baseband and the rest of the ROM both from the same rev, -OH1, my Wi-Fi is working again!

    How do I explain the Wi-Fi was working too earlier? It's because I flashed the -QB1 ROM at that time. Thus, the baseband and the rest of the ROM was the same rev too at -QB1.

    Now my baseband is back to the same rev as my Nandroid copy, -OH1. I restore my Nandroid copy and my Wi-Fi is working again!!! Huray!

    I am not saying the baseband and the rest of the ROM always have to be from the same rev. Most custom ROM don't even come with the baseband. However, there is something funny about this I337MVLSGQB1 code. It is the same Android rev, 5.0.1, as the previous one, -OH1, issued 2 years earlier. Why did Samsung even bother? Well, they call it security fix. I don't know what exactly they fix, but I did observe a restriction. When I tried it last time, it prevented me from freezing bloatware using SD Maid. I couldn't tolerate it and went back to -OH1. I didn't know the baseband was still stuck at -QB1 and only the rest of the ROM went back to -OH1. Since I rarely use Wi-Fi, neither did I know this particular incompatibility also prevents the Wi-Fi from working!

    In summary, make sure your baseband is not I337MVLSGQB1. If it is, then also make sure the rest of the ROM is also -QB1. If you don't like the "improvement" provided by -QB1, then downgrade from it, but make sure it is indeed downgraded. The -QB1 baseband may still be stuck in your device unless you specifically burn the modem.bin file from the rev you intend.

    These are the stock ROM for the Canadian version of S4. If yours is AT&T, they will be different. However, if you come across a security fix issued in 2017 on Android 5.0.1, I am almost sure it will cause the same problem if you mix components of this rev with the previous one issued in 2015. The Canadian and AT&T versions of S4 are almost the same except the AT&T one has a locked bootloader, which prevents you from installing custom recovery and ROM. Avoid AT&T/Verizon phones at all cost if you are a hacker! My Canadian S4 is working great in the U.S. After all this AT&T protection (or limitation depends on how you see it) will not protect you when you mix two different versions of AT&T ROMs.
    03-04-2018 09:54 PM
  6. luckysoul777's Avatar
    [Updated: one day later...
    It turned out in addition to the Wi-Fi problem, which I solved yesterday by flashing modem.bin, I also had a hotspot problem. When I tethered my laptop through my S4, the connection would drop in a few seconds! After mucking around for half of a day, I finally realize although under About device it is showing I have the -OH1 baseband, modem.bin is only half of the story. There is another file, NON-HLOS.BIN I also have to flash! Now, I have a solid tethering connection!
    03-06-2018 04:00 AM
  7. kapilakumaradhananjaya's Avatar
    s4 catlog

    I tried all the options that you can think of! I could not make it work! The interesting thing to me is that when I put Dirty Unicorn rom, wifi works....but i want stock rom...
    off data
    03-08-2018 01:48 PM
  8. rram0405's Avatar
    GUYS I struggled with this wifi issue for 2 weeks and it was TORTURE and this method did not work for me because I couldn't turn on my tethering to start with. BUT I FINALLY FOUND MY FIX!! bAsIcaLLy, you have to turn off your power saving mode. IF ITS NOT SHOWN AS TURNED ON ALREADY, TURN IT ON. Then, type *#0011# into your dialler, click the drop down menu and select wifi, then hit OFF. Restart your phone, and the problem should be gone. Hope it works for u because not having wifi all day is tortureee 
    06-04-2018 08:43 PM
308 ... 111213

Similar Threads

  1. Replies: 19
    Last Post: 10-11-2015, 05:26 PM
  2. Speed up the galaxy S4 and enable the developer mode
    By MallyMall88 in forum Samsung Galaxy S4
    Replies: 21
    Last Post: 11-09-2014, 02:28 PM
  3. DNS not available on Wi-Fi settings on Nexus 10
    By regalhawk in forum Google Nexus 10 Tablet
    Replies: 3
    Last Post: 11-08-2013, 07:32 AM
  4. In-app Videos only playing on Wi-Fi
    By ajbrickyard in forum HTC One M7
    Replies: 6
    Last Post: 07-01-2013, 04:57 PM
  5. [Q] Wi-fi problems.
    By tomy22783 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 06-25-2013, 10:26 AM
LINK TO POST COPIED TO CLIPBOARD