All of my info got removed after repair..

Kraken24

New member
Mar 3, 2014
4
0
0
Visit site
As the title says,all of my data has been removed after my S3 screen was fixed.
And now,I can't enter Google play because It says that I have Problem communicating with Google servers.

Any solutions?
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,946
3,967
113
Visit site
Welcome to Android Central! It isn't surprising that the phone got wiped, because they probably had to do a full factory reset. Your Google data would have presumably been synced to your account, so that shouldn't be too hard to restore. When you got the phone back, did you have to go through the whole setup process as if it was just out of the box? And you logged in with your main Google account?
 

Kraken24

New member
Mar 3, 2014
4
0
0
Visit site
Welcome to Android Central! It isn't surprising that the phone got wiped, because they probably had to do a full factory reset. Your Google data would have presumably been synced to your account, so that shouldn't be too hard to restore. When you got the phone back, did you have to go through the whole setup process as if it was just out of the box? And you logged in with your main Google account?
Well, They just asked me to log in with an account, I did,and thats what happend.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,946
3,967
113
Visit site
So did you log in with your main Google account? The one that you used prior to sending it in for the repair?

Posted via Android Central App
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,946
3,967
113
Visit site
Problems with Google server communication can be temporary, so it's difficult to say if the issue is with the phone or on Google's side. Are you connecting via wifi or mobile data?

I also wonder if there might be some problem with your version of Google Play Services--this should be updated automatically, so you might have to wait until that's done (usually happens pretty quickly).
 

Kraken24

New member
Mar 3, 2014
4
0
0
Visit site
Problems with Google server communication can be temporary, so it's difficult to say if the issue is with the phone or on Google's side. Are you connecting via wifi or mobile data?

I also wonder if there might be some problem with your version of Google Play Services--this should be updated automatically, so you might have to wait until that's done (usually happens pretty quickly).
Well,I have fixed this by removing the account and connecting again.
Anyway,the main problem is that all my Photos are gone.....