Android 14 tomorrow?

maverick7526

Well-known member
Jun 24, 2011
1,386
75
48
Visit site
This always makes me a little mad lol. It's like why don't they release it to Google Fi right away? It should be one of the perks of being with Fi and supporting Google.
That makes sense since it is Google's carrier. Since they use TMO though is probably why it's delayed. Ever since they shut down Sprint, they have become more "Carrier-like" than UN-carrier like they used to tout. Probably this week sometime though. It looks like it was hitting Europe yesterday.
 

maverick7526

Well-known member
Jun 24, 2011
1,386
75
48
Visit site
I wouldn't mind if they would just explain why updates are delayed for TMO each month. A communication to say when we can expect it, so I don't have to hit the "Check for update" button every 3 minutes for a week.
That would require Google to be transparent about information. Which they never really are about updates.

Like when the Dec update for the P6 was bricking radios, and they didn't say anything all month, even though there were many reports etc. Then randomly on NYE, they dropped a small blurb on the images page, and pulled the OTA files.

I enjoy Google/Android, however at times dealing with some of their decisions can be quite irksome.
 

Tomster88

Well-known member
Apr 13, 2014
879
119
43
Visit site
That would require Google to be transparent about information. Which they never really are about updates.

Like when the Dec update for the P6 was bricking radios, and they didn't say anything all month, even though there were many reports etc. Then randomly on NYE, they dropped a small blurb on the images page, and pulled the OTA files.

I enjoy Google/Android, however at times dealing with some of their decisions can be quite irksome.
Agreed
 

Macdtek

Well-known member
Feb 26, 2017
208
16
18
Visit site
I had the OTA update arrive on Thursday and everything went well for a day. Then late yesterday afternoon I noticed the rise to wake and tap to wake weren't working. Checked the settings and both were turned on. Rebooted and nothing. Then I noticed some apps seemed to be flickering and no notifications coming through. Again all is ok in settings. So I bit the bullet backed it all up and did a factory reset and this fixed it. I noticed the play store had an update so updated that. Then the same issues started again. So another factory reset and this time all the apps were greyed out on re stating. Haven't even looked at the play store updates as all is well now (again). Must be some kinda bug somewhere.
 

Macdtek

Well-known member
Feb 26, 2017
208
16
18
Visit site
Well today the sim card is fritz'd. Wont work in my pp7 or my wifes moto. Her sim works in my pp7 though. So my issues could be a sim issue. New one ordered.
 
  • Like
Reactions: Tomster88

Trending Posts

Forum statistics

Threads
941,409
Messages
6,908,730
Members
3,157,914
Latest member
carlossinsurance