• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

Bad SIM card or something wrong with my Nexus 5...?

jrdatrackstar1223

New member
Dec 19, 2009
315
10
0
Recently, I had to switch to using a T-Mobile Straight Talk Micro SIM card because I had to wait on a replacement from Straight Talk for my AT&T SIM card. As soon as I started using that SIM I noticed horrible battery life. After using the phone, I see the phone fluctuate/bounce between 3G, H, and LTE. This happens whenever I use internet, text, or make phone calls. It'll drop to 3G, jump back to H (or just drop from LTE to H and stay there), and then back to LTE after some time.

My question is, has anyone else seen this behavior in their Nexus 5 with a T-Mobile SIM (particularly Straight Talk, but I guess T-Mobile in general)? I am on the latest build MOB30H. I wanted to hold off putting the AT&T SIM in my phone until I can get some answers on this because I don't want to risk that one expiring (Straight Talk SIMs expire if you transfer your number to another SIM).
 

Laura Knotek

Moderator Captain
Moderator
Jan 8, 2011
10,364
4
38
It could just be that T-Mobile coverage in your area is bad. Is T-Mobile servicing any towers?
 

jrdatrackstar1223

New member
Dec 19, 2009
315
10
0
It could just be that T-Mobile coverage in your area is bad. Is T-Mobile servicing any towers?

Thanks for your reply. I'm not quite sure actually, I just know that I at least get LTE service and it will stay on LTE until I start to actually use the phone. If I just stare at the screen it shows LTE, but when I open the web, browse the store, etc, it drops to 3G/H.
 

Laura Knotek

Moderator Captain
Moderator
Jan 8, 2011
10,364
4
38
Thanks for your reply. I'm not quite sure actually, I just know that I at least get LTE service and it will stay on LTE until I start to actually use the phone. If I just stare at the screen it shows LTE, but when I open the web, browse the store, etc, it drops to 3G/H.
Have you tried the T-Mobile SIM in another phone? If so, what happens?
 

jrdatrackstar1223

New member
Dec 19, 2009
315
10
0
Have you tried the T-Mobile SIM in another phone? If so, what happens?

I will try with my Lumia Icon. I spoke with Straight Talk and he gave me totally different APN settings than what is posted on even their own website. It appears LTE is "sticking" now, we'll see in a little while. Thanks for you help!
 

belodion

Co-Ambassador Team Lead
Moderator
Jun 10, 2014
39,073
0
36
I will try with my Lumia Icon. I spoke with Straight Talk and he gave me totally different APN settings than what is posted on even their own website. It appears LTE is "sticking" now, we'll see in a little while. Thanks for you help!

Doesn't the Icon use a nanoSIM? I have the Lumia 930, which does. Unless you plan to cut. :)
 

belodion

Co-Ambassador Team Lead
Moderator
Jun 10, 2014
39,073
0
36
^ You're not alone....I've planned switches from one phone to another myself and then remembered the size difference.