Can't update to 7.1.1

Jakx1122

Member
Feb 8, 2017
15
0
0
Visit site
The update downloads fine and when I click 'restart and install' it proceeds to start the installation but shortly after I get an 'error' message and the phone restarts itself. Then I get another update notification a day later. It's been like that since early December... Why? I'm using Nexus 6p
 

HaboobZ

Well-known member
Jun 9, 2015
231
0
0
Visit site
A shot in the dark, but I just saw on Reddit that someone had an issue with downloading the update due to AdGuard. Are you running anything like that? They said they disabled it and it downloaded just fine afterwards - granted yours has downloaded, but maybe there's an app similar to this that's preventing the installation?
 

GSDer

Well-known member
Jan 30, 2011
8,471
15
0
Visit site
Forgot to ask the OP - what's the exact error message you're seeing after the installation begins?
 

Jakx1122

Member
Feb 8, 2017
15
0
0
Visit site
I don't have AdGuard or anything like that.
And there's nothing else but "Error" displayed. No number, no code, nothing. Just "Error".
 

Mikey D_PhD

Well-known member
Apr 4, 2011
427
33
28
Visit site
If you apply the OTA via ADB, you won't erase the data. That's the route I took and haven't had issues. Be careful to go to the OTA files page and not the factory images page.
 

GSDer

Well-known member
Jan 30, 2011
8,471
15
0
Visit site
The update downloads fine and when I click 'restart and install' it proceeds to start the installation but shortly after I get an 'error' message and the phone restarts itself.
When you say 'it proceeds to start the installation' does you mean that it reboots into Recovery and starts the installation, or is it failing before it even reboots into Recovery?
And there's nothing else but "Error" displayed. No number, no code, nothing. Just "Error".
Have you tried booting into Recovery mode and clearing the system cache? Perhaps you got a corrupt download and that's why it keeps failing.
 

Jakx1122

Member
Feb 8, 2017
15
0
0
Visit site
When I say it proceeds to start the installation I mean everything is the same way it's always been with updates. The phone restarts itself, there's a big, colored, moving, circle that represents the update installing. There's a bar right underneath it that shows me the progress of the installation, and about 1/4 into the installation it stops and there's a picture of a green Android robot with an Error message under it. Then the phone just restarts itself. And a day later I get another update notification.

Yes I have tried clearing the system catche. Somebody above suggested it earlier. Didn't work.
 

bjrosen

Well-known member
Mar 19, 2011
751
3
0
Visit site
Doing a fresh install really isn't that bad. If you are using Nova Launcher do a backup to the Google Drive before you do the install, when your restore is done you load the backup and your layout will get restored. Google backs up all of your apps and will automatically restore them if you tell it to do so. Google apps are completely backed up, third party apps that use logins will require you do do that by hand. Your Photos should all be automatically backed up to Google Drive and to Dropbox if you are using that, so you don't have to worry about that. If you have a lot of mp3s and such that aren't in the cloud you will have to restore them also but that's easy, just copy them to the cloud or to your PC and then copy them back after the fresh install. I do clean installs fairly frequently because I don't like to wait for the OTAs. Clean install fix a lot of things. It might cost you an hour of your time but you will be happier with your phone once you've done it.
 

Forum statistics

Threads
942,814
Messages
6,915,993
Members
3,158,665
Latest member
Ramki