HTC Droid Eris: Voicemail notification icon won't go away

Kbuxx70

New member
Feb 8, 2010
4
2
0
Visit site
The icon will not go away now. I do not have any voicemails and it remains there. Even when I have two, the notification icon just shows a 1. Any ideas on how to get it off?
 
Last edited by a moderator:
  • Like
Reactions: Clutch Cargo

Kbuxx70

New member
Feb 8, 2010
4
2
0
Visit site
tried the clear button but it doesn't go away like the text notifications do. Soft reset doesn't do anything for me either.
 

muaruader12

Member
May 18, 2009
8
0
0
Visit site
You need to listen to all of your voicemail messages until you hear the words main menu when the messages are done playing. The notification will stay up until the messages are listened too, its just a small glitch in the android coding.
 

stunnly

New member
Nov 6, 2010
1
0
0
Visit site
How I got the voicemail icon to go away

I have Google Voicemail enabled on my Verizon line. I had my phone line forwarded to the Google Voicemail. I went online to Google Voice account and followed the instructions to deactivate the call forwarding from my regular number. Then I called Verizon's voicemail and somehow there was a new message in there that had slipped between the cracks. I listened to that email and the icon went away. I then went back to the Google Voice account and followed the instructions on activating the call forwarding again. Life's good!!:cool:
(I still can't figure out how the voicemessage got through the crack and into a 'hidden' voicemail box.?!?!?!?
 

rolobolo44

New member
Apr 13, 2011
1
1
0
Visit site
EVO

THIS 100% WORKS!! and its completly easy.
Go to your settings, then go to applications, (youmight have to click on "all" then go to manage applications, then scroll all the way down to voicmail, tap voicemail, then scroll down to force stop. Then tap force stop, and the icon goes away. It temporaraly stops your voicemail, but once you tap on the voicmail app, it starts again without the icon.
 
  • Like
Reactions: spikenshel

Feral Ginger

New member
Jun 13, 2011
1
0
0
Visit site
THIS 100% WORKS!! and its completly easy.
Go to your settings, then go to applications, (youmight have to click on "all" then go to manage applications, then scroll all the way down to voicmail, tap voicemail, then scroll down to force stop. Then tap force stop, and the icon goes away. It temporaraly stops your voicemail, but once you tap on the voicmail app, it starts again without the icon.


Didn't actually work for me.

"settings > call settings > clear voicemail notification"

I thought I'd tried everything but somehow managed to miss this one. Worked like a charm.
 

harbie221

New member
Jul 31, 2011
1
0
0
Visit site
Re: EVO

THIS 100% WORKS!! and its completly easy.
Go to your settings, then go to applications, (youmight have to click on "all" then go to manage applications, then scroll all the way down to voicmail, tap voicemail, then scroll down to force stop. Then tap force stop, and the icon goes away. It temporaraly stops your voicemail, but once you tap on the voicmail app, it starts again without the icon.
Thank you rolobolo44! You saved my sanity!! :)
 

Zlurpo

New member
Sep 7, 2010
4
0
0
Visit site
Re: Voicemail notification icon won't go away

I have the same problem. But in Settings>Call settings> There is NO "clear voicemail notification" option, nor anything like it. Settings>call settings>Voicemail has nothing either. If I go to Settings>Applications>Running Services, Voicemail is not running. And the voicemail icon is still there, despite having no messages, new, old, or saved. I am not using Google Voice, or any other similar program, just the regular voice mailbox system that came with the phone (Samsung Vibrant). I've never had this issue before. How do I get rid of it?
 

walt555

New member
Oct 17, 2011
3
0
0
Visit site
THIS 100% WORKS!! and its completly easy.
Go to your settings, then go to applications, (youmight have to click on "all" then go to manage applications, then scroll all the way down to voicmail, tap voicemail, then scroll down to force stop. Then tap force stop, and the icon goes away. It temporaraly stops your voicemail, but once you tap on the voicmail app, it starts again without the icon.
 

walt555

New member
Oct 17, 2011
3
0
0
Visit site
Re: Voicemail notification icon won't go away

Ty !!! That stupid icon was driving me nuts !! I would never have thought to force stop it in the apps menu. Thanks again
 

lanreb

New member
Jul 12, 2010
4
0
0
Visit site
Re: Voicemail notification icon won't go away

I have the same problem. But in Settings>Call settings> There is NO "clear voicemail notification" option, nor anything like it. Settings>call settings>Voicemail has nothing either. If I go to Settings>Applications>Running Services, Voicemail is not running. And the voicemail icon is still there, despite having no messages, new, old, or saved. I am not using Google Voice, or any other similar program, just the regular voice mailbox system that came with the phone.

I am in the same boat as you on my T-Mobile G2.

I'm still hoping to find a solution, because I'm a little OCD with clearing my notifications :-\
 

lanreb

New member
Jul 12, 2010
4
0
0
Visit site
Re: Voicemail notification icon won't go away

Leaving a T-Mobile voicemail for myself, then deleting the voicemail worked for clearing the "new voicemail" notification icon.

However, even though I had already turned Google Voice off, I had to manually disable each call forwarding option for me to be able to reach my T-Mobile voicemail instead of Google Voicemail (Settings > Call settings > Call forwarding).
 

Nirvana328

Well-known member
Jun 20, 2010
59
3
0
Visit site
Re: Voicemail notification icon won't go away

For anyone who is still having issues with their Voicemail notification icon and none of the above options worked, this might work for you.

Go to settings > call settings > voicemail settings > voicemail number

I'm using an HTC Nexus One on Android 2.3.6 (stock), on T-Mobile. For me it had some weird long distance number. When I changed this number to my cell phone number, it IMMEDIATELY removed the voicemail notification icon. BUT WRITE DOWN THE ORIGINAL VOICEMAIL NUMBER FIRST, AS A REFERENCE, BEFORE YOU CHANGE THE SETTINGS.

Just as an aside, I use Google Voice as my primary voicemail system (but I didn't port my number or create a full Google Voicemail account). Like someone said above I had to reset all the call fowarding settings (settings > call settings > call forwarding) so my voicemail would go through T-Mobile and not Google Voice. I also had to recently change my SIM card and that's when this started. So I'm aware the HTC Eris is a Verizon phone, but this was my experience and what I did to fix the problem using a stock Gingerbread phone on T-Mobile.

Interestingly, after clearing the strange long distance default voicemail number, when I put it back in as the voicemail number, the notification icon did not return. So I guess this helps even if you don't have a google voice number. Hope this helps. :cool:
 
Last edited:

bszyd

New member
Jan 22, 2012
1
0
0
Visit site
Re: Voicemail notification icon won't go away

I don't use Google Voice and I had no "clear notification" or force stop of the application. I just left a new voicemail, deleted it and the original icon went away. Ridiculous solution for this problem but it seemed to work.
 

Forum statistics

Threads
943,065
Messages
6,917,130
Members
3,158,806
Latest member
Mossi