S4 mini, boot loop, no recovery and can't load stock firmware.


AC Question

Hallo. Down to details.

Phone is a bit old.
Not rooted or unlocked.
S4 mini 9190
When I turn it on, shows Samsung screen and loops constantly.
When I go into recovery, I get the android logo on it's back with the red triangle. Tried everything to get past it. Nothing.
I can, however, get into download mode. I tried loading stock firmware back with Odin, but stays the same. Tried BL, AP, CP and CSC. Separately and all together.
Any help would be appreciated.

Thanks in advance.


Well-known member
May 16, 2014
Visit site
Try downloading the stock ROM for your S4 mini (GT-I9190) from here:
Note that you need to get the ROM for your specific model and locale (country and carrier), there's no mix-and-matching involved, no substitutions.

Now get a version of Odin that compatible with what you're working with, it this case apparently v3.09.
Newer versions of Odin are not very backwards compatible so this is an instance where you don't want the latest version.

The sammobile download page will have basic instructions at the bottom so try re-flashing again. Follow the directions to use Odin as stated, it's just not a good idea to experiment with the different options like that. And if you did do something like select the 'Re-partition' option before, you'll also need to find the appropriate PIT file (Partition Information Table) for your model.
Also when experimenting with Odin if your phone is completely bricked, try using a jig to restore it. You can make your own:
or pick one up on Amazon (they're only a few bucks)