Question Twitter (X) Notifications not working/ not working well

sandraa0520

Member
Oct 14, 2013
5
2
3
Visit site
Hi

I cannot get Twitter notifications to work correctly. Other apps will light up the screen if locked, on unlocked phone I will receive a pop up on top of the screen along with sound and vibration.

Twitter notification will only appear in the notifications list but the phone does not alert me, so no light up on a locked screen, no pop up on unlocked, no sound nor vibration. It's annoying really. this is happening on a samsung note 20 Ultra but had the same thing happen on s23 ultra when I had it for a week.

Works normally on my iPhone that I'm switching to android from, and in fact, I'll have 100 notifications on the iPhone and only ~30 on the Android. Watch 5 also has the notification in notifications list but same as phone, it doesn't alert me that I'm getting the notification.

Things I have tried: Turn phone off and on :ROFLMAO:, didn't bother resetting since I just set it up and it was the same issue on another Samsung phone. all notification are set to "on" in the app itself, all notifications enabled in phone settings under the Twitter app, pause app activity if app unused is off

thanks
 
Solution
Hmm, I don't use X, so it's hard for me to test. Did you already try clearing the app cache/data for X in Settings>Apps, then force stopping it, and opening it again?
Okay after going as far as doing a smart tutor with text support, and then a walk in at the samsung walk in service center and them not knowing what the issue is and their only solution being they wanted to do a software flash but I didn't, I FINALLY figured it out....so posting here in case someone else with same issue stumbles upon this. After noticing amazon shopping app was having the same issue, gmail as well, I started exploring.

So, settings -> apps -> click on app (in this case, X) -> notifications -> notification categories

and then in here...

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,931
3,928
113
Visit site
Welcome to Android Central! Go to Settings>Apps, select X, then Notifications. Do you see the category for Notification Types? If so, are "Lock Screen" and "Pop-up" set to Allowed?
 
  • Like
Reactions: Laura Knotek

sandraa0520

Member
Oct 14, 2013
5
2
3
Visit site
Welcome to Android Central! Go to Settings>Apps, select X, then Notifications. Do you see the category for Notification Types? If so, are "Lock Screen" and "Pop-up" set to Allowed?
hi! thanks!
so, lock screen, badge, and pop up are allowed, allow sound and vibration is selected, lock screen notifications are set to show content

and idk if it matters but ive tried it with a current play store version, and an older version of a mod apk

I also have a tablet running stock android, and it's the same thing. notifications are there but they make no sound when i get them.

AND, on the phone if i go to twitter in Chrome browser, and turn on push notifications there, it'll make a sound when the notification comes.

I'm so confused, why would the app not work ONLY on all of my android devices?
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,931
3,928
113
Visit site
Hmm, I don't use X, so it's hard for me to test. Did you already try clearing the app cache/data for X in Settings>Apps, then force stopping it, and opening it again?
 

sandraa0520

Member
Oct 14, 2013
5
2
3
Visit site
Hmm, I don't use X, so it's hard for me to test. Did you already try clearing the app cache/data for X in Settings>Apps, then force stopping it, and opening it again?
Just tried, restarted the phone too. Didn't work. It just seems so strange that it's across all my android devices. I wonder if it's like somehow tied to my account, but then it works fine with the browser notifs so I don't know.
 

Laura Knotek

Moderator Captain
Moderator
Jan 8, 2011
11,553
3,331
113
Visit site

mustang7757

Super Moderator
Moderator
Feb 6, 2017
90,641
5,250
113
Visit site
Finally got a notification after almost a day installed on lock screen
6357468442790b247d42c85ac42db9a7.jpg
 

sandraa0520

Member
Oct 14, 2013
5
2
3
Visit site
Hmm, I don't use X, so it's hard for me to test. Did you already try clearing the app cache/data for X in Settings>Apps, then force stopping it, and opening it again?
Okay after going as far as doing a smart tutor with text support, and then a walk in at the samsung walk in service center and them not knowing what the issue is and their only solution being they wanted to do a software flash but I didn't, I FINALLY figured it out....so posting here in case someone else with same issue stumbles upon this. After noticing amazon shopping app was having the same issue, gmail as well, I started exploring.

So, settings -> apps -> click on app (in this case, X) -> notifications -> notification categories

and then in here there is "allow notifications" and a bunch of other options under that such as "tweets from people you follow" "direct messages" etc etc

if you click on allow notifications it simply turns it on or off, but then once you click on any of the other categories it takes you into further settings where you can pick an individual notification sound (my direct messages were set to sound but tweets from people you follow were set to silent) AND turn on or off "show as pop-up" which in my case was ON for messages (and was working when I was testing prior to figuring this out) and was OFF for my tweets from ppl I follow. once I set all of the categories to allow pop up and set the sound, all is working. For all the apps that weren't working so twitter (X), amazon AND gmail. Oh, and also that of course fixed the notification on watch as well.
 
Solution

mustang7757

Super Moderator
Moderator
Feb 6, 2017
90,641
5,250
113
Visit site
Okay after going as far as doing a smart tutor with text support, and then a walk in at the samsung walk in service center and them not knowing what the issue is and their only solution being they wanted to do a software flash but I didn't, I FINALLY figured it out....so posting here in case someone else with same issue stumbles upon this. After noticing amazon shopping app was having the same issue, gmail as well, I started exploring.

So, settings -> apps -> click on app (in this case, X) -> notifications -> notification categories

and then in here there is "allow notifications" and a bunch of other options under that such as "tweets from people you follow" "direct messages" etc etc

if you click on allow notifications it simply turns it on or off, but then once you click on any of the other categories it takes you into further settings where you can pick an individual notification sound (my direct messages were set to sound but tweets from people you follow were set to silent) AND turn on or off "show as pop-up" which in my case was ON for messages (and was working when I was testing prior to figuring this out) and was OFF for my tweets from ppl I follow. once I set all of the categories to allow pop up and set the sound, all is working. For all the apps that weren't working so twitter (X), amazon AND gmail. Oh, and also that of course fixed the notification on watch as well.
Interstate clearing data on that app and force stop should set it to the default value but glad it looked it over and now it is good.
 

Trending Posts

Forum statistics

Threads
941,369
Messages
6,908,332
Members
3,157,882
Latest member
Raccoon