Wi-Fi Calling not always working even though WiFi Signal is very good

jrsee

Member
Jan 27, 2023
7
0
1
Visit site
UK Based - Mobile Service Provider: Virgin Mobile. Phone: Pixel 6a (Android 13). Internet Service Provider: Virginmedia (via cable).
Mobile signal has always been patchy at home, coming and going at random, and my previous phone (Motorola G6) did not support WiFi Calling, so I upgraded to the Pixel 6a just before Christmas. I turned the Wi-Fi Calling setting on; and I had previously checked that Virgin Mobile would support the facility on my contract.
WiFi Calling does work, but ONLY when the phone has a mobile signal. When the mobile signal is weak (much of the time) calls ARE made via WiFi Calling ("Virgin Wi-Fi Calling" is displayed top LH side of screen). But when there is no mobile signal, indicated by a triangle icon (top RH of screen), with an exclamation mark on the right edge (and "No Service" at top left), I can't make a call or send a text, and the message "Mobile network isn't available. Connect to a wireless network to make a call." is displayed. Given that I can see that am connected to my router (approx 5 metres away), this seems a particularly unhelpful message. Someone did explain that my internet connection/router also needs to be connected to the mobile network, but how would my phone know whether my router/internet was connected to a mobile network anyway? And if this were the case, what on earth is the point of Wi-Fi Calling? If my phone hasn't got a mobile signal, my router is unlikely to have one. On the plus side, calls do seem to be better quality, and I haven't had one drop out once I have made a connection via Wi-Fi Calling.
Am I missing something? I have Googled several times to try and find out what I needed to do to use Wi-Fi Calling, but all I can ascertain is that the W/Calling setting has to be on (it is), and that my mobile service provider has to support the facility (it does).
Thanks in advance.
 

ras47

Well-known member
Mar 21, 2021
268
24
18
Visit site
Your carrier might support WiFi calling but it may not be activated on your plan. Or you might need a new SIM card for this service to work.
 

rvbfan

Well-known member
Jan 17, 2015
1,860
1,607
113
Visit site
Sounds like you are going to have to get in touch with your provider again.
Guessing they didn't check to see if it was actually turned on on their side.

Sent from my Pixel 6 using Tapatalk
 

SpookDroid

Ambassador
Jul 14, 2011
19,340
618
113
Visit site
A little tricky when it comes to WiFi Calling. Yes, for that to work, your WiFi router does need to be 'connected' to the mobile network; this doesn't mean that it is receiving the connection from your carrier, but rather that it can reach their servers via Internet. Now, that's where things get tricky. If the carrier doesn't have reliable servers, this connection may be dropped, so no matter how much your router tries, it cannot communicate with the carrier, essentially resulting in the same as not having a cellular signal: no service. Another possibility is that either your router or Internet provider may be blocking traffic for VoIP or to the carrier's servers/required ports.

Something that may help is setting your WiFi Calling preferences to "Wi-Fi Preferred"; that way your phone will always prioritize getting a signal through WiFi rather than mobile and may keep your phone connected just in case something is off with the mobile network.

Another thing to try is doing this in a different router or WiFi network to see if it's your connection/router causing the issues.

As posters above have said, too, the carrier may need to do some tinkering on their side (although, if you HAVE made WiFi calling calls, this is less likely, but can't hurt to have them check).
 

jrsee

Member
Jan 27, 2023
7
0
1
Visit site
I did talk to my supplier who said that it would not be a problem, but that I might need a new sim card, which they sent me, and I put in my phone. So I don't think that's the answer, but thank you for the suggestion.
 

jrsee

Member
Jan 27, 2023
7
0
1
Visit site
Most of my calls are being made via WiFi Calling, so I don't think that's the answer, but thanks for the suggestion. It just doesn't seem to work when the phone has no mobile signal.
 

jrsee

Member
Jan 27, 2023
7
0
1
Visit site
Thanks. It is clear that I do need to talk to my carrier (Virgin) again. I can't actually find a "Wi-Fi Preferred" setting. Under Wi-Fi Calling the only option is "Use-Wi-Fi calling" (either on or off). The explanatory narrative says "When Wi-Fi calling is on, your phone can route calls via Wi-Fi networdks or your mobile's network, depending on your preference and which signal is stronger. Before turning on this feature, check with your operator regarding fees and other details". I'll try next time I'm in the pub where I often don't have a mobile signal but can use their Wi-Fi, but I'm pretty certain I couldn't make a call from a neighbour's house (no mobile signal, but I was on their WiFi), and it didn't work until I went outside, so I don't really think that's the answer. It sounds like what you say in your first para is the likely problem! Thanks very much for your reply (and sorry not to have responded to any of those who replied for several days - family visiting from New Zealand!).
 

SpookDroid

Ambassador
Jul 14, 2011
19,340
618
113
Visit site
Keep us posted on whether this worked on a different WiFi Network or not! Also, if can have someone with the same carrier try to do WiFi calling on a different phone (or let you use your SIM in their phone) just to test it out, that could help pin-point where the problem might be.
 

jrsee

Member
Jan 27, 2023
7
0
1
Visit site
Somehow time has slipped away (NZ visitors, trips away, and some sickness), and over three months have passed, and no resolution. I have spoken to Virgin again, and they say I should talk to Google - they claim that WiFi Calling is on and should work (which it does, but only when there's a mobile signal, as previously described). They cannot explain why it doesn't work for me when there is not mobile signal, becasue they say that it should - so I should take to the phone manufacturer and/or someone at Android - i.e. basically they are saying it's Google's problem. I had hoped that people from Google would read this forum, and possibly help where they can provide an answer - maybe they don't (read the frum), or can't (provide an answer).Very disappointing. Don't really have a clue where to start with trying to contact someone. I've looked at trying to "ask the community" on the Google support website, and I have to say I just go round in circles - it tells me how to check my phon settings (done al that - they are corrctly set); it says to contact my provider (done that); it says if I'm in the UK, to try the {ixel UK help centre, which simply takes me to the page I have just come from. Absolutely useless.
 

jrsee

Member
Jan 27, 2023
7
0
1
Visit site
As it happens, I have just done a bit more digging, and I have found a solution on Reddit which works for me (although apparently not for everyone), and although it does work for me, it still doesn't make sense. If anyone could explain why it works I would be very grateful! Anyway, the solution (for me) is to turn airplane mode on, and make sure WiFi is also on, and I can make and receive calls using WiFi calling - obviously (I assume!) this must be totally independent of the mobile network. But to reiterate my issue, when I am not in airplane mode, but I am connected to WiFi, I can only use WiFi calling if I am also connected to the mobile network (WiFi Calling only kicks in if the the mobile connection is weak, but a connection definitely has to be there). So, what I have to do is turn Airplane mode on at home, and when I'm anywhere where I have a WiFi signal, but the mobile signal is iffy (and make sure I have Wifi on - apparently my phone will remember that I have set WiFi on while airplane mode is on - it told me just now). Bit of a pain, but I think it solves my problem. I'd still like to know why this works though.
 

jrsee

Member
Jan 27, 2023
7
0
1
Visit site
A postscript: Airplane mode works, but when turning it on, I need to have a mobile signal. If I don't, then when trying to make a call, I get a message saying "Radio Off" (sometimes) or "Mobile network not available" (at other times). So in my particular circmstances, I just need to turn airplane mode on before I get home since I have a signal when I'm out in the street. I have incidentally checked on other WiFi networks (like in my local pub) and I can make and receive calls with airplane mode on, and I can also send SMS text messages. There is, however, another problem, which is I don't receive SMS text messages, so I send out a message, but don't receive the reply, which has been sent (it will eventually turn up maybe a day or so later when I am operating in "normal"mode (i.e. not airplane mode). HOWEVER, I have just discovered that if I am exchanging messages with someone where the messages are RCS (I have only just come across this, and it appears to be only applicable to relatively recent Android phones), I DO receive their replies. I really am at a loss with how to make sure I can use WiFi calling with confidence!
 
Apr 25, 2024
1
0
1
Visit site
Just FYI, I'm having the exact same problem with my Galaxy S23 in 2024, and have been having the problem for months. Thanks for sharing the details of your symptoms. It's nice to know I'm not the only one.

Broadband provider is Virgin Media, but I've had two different mobile providers in the time I've been having problems - GiffGaff (which doesn't support WiFi calling, and is the reason I switched away) and Smarty (which does support WiFi calling).
When WiFi calling works, it's great. But at least half the time I'm at home, it doesn't work, even when it's enabled on the phone. We have strong WiFi 5 throughout the house, fast broadband and a terrible mobile signal, so why the phone doesn't select it all the time god only knows.

I've spoken to Smarty tech support and they were no use.

I'll try doing a packet trace on the router to see if I can spot any traffic anomalies when it's not working.
 

JT1981

New member
May 8, 2024
1
0
1
Visit site
Just FYI, I'm having the exact same problem with my Galaxy S23 in 2024, and have been having the problem for months. Thanks for sharing the details of your symptoms. It's nice to know I'm not the only one.

Broadband provider is Virgin Media, but I've had two different mobile providers in the time I've been having problems - GiffGaff (which doesn't support WiFi calling, and is the reason I switched away) and Smarty (which does support WiFi calling).
When WiFi calling works, it's great. But at least half the time I'm at home, it doesn't work, even when it's enabled on the phone. We have strong WiFi 5 throughout the house, fast broadband and a terrible mobile signal, so why the phone doesn't select it all the time god only knows.

I've spoken to Smarty tech support and they were no use.

I'll try doing a packet trace on the router to see if I can spot any traffic anomalies when it's not working.

I use ATT and a Cox Wifi router with Galaxy S23 and have the exact same issue with wifi calling. It started a few months ago after a phone update in March. I noticed it happening a lot right before ATT was hacked. The issue appears to be how the phone is communicating with the cell tower while wifi calling is turned on. If your phone keeps getting a slight signal but then loses it this is when the problem arises as it seems to be trying to switch back and forth between using the tower and using the wifi even if you set it to use wifi calling priority when on wifi. Switching to airplane mode and then turning on wifi calling sometimes works, but as another user pointed out if you go into airplane mode before having a cell signal than calls do not come in to your device so if you forget to turn it on before getting in the the area with a bad/no signal your SOL. Resetting your phone also seems to work as it appears to reach out with a slightly stronger signal for a moment to find a cell tower but after about 15 mins the same issue arises. I'm not sure who to reach out about this anymore but I hope someone at Samsung addresses it, because I have a feeling something got messed up with the wifi (like the priority setting) and it got missed.
 

Trending Posts

Forum statistics

Threads
944,422
Messages
6,922,756
Members
3,159,552
Latest member
Lawrick