E: failed to mount /efs (invalid argument)

Tech_Analysis1

New member
Jun 30, 2014
3
0
0
Visit site
Hi there,

I have the same problem I think. When I turn on my Galaxy S3 it does not boot past the Samsung Logo. I have pulled the battery on several occasions. This does not work.

I then try to boot into the recovery console and have a few options that dont resolve my issue. However in the recovery mode I see the error "E: failed to mount /efs (invalid argument)"

I have put the phone into download mode and tried the firmware upgrade and initialsation and I get a message saying this device cannot be updated.

Any ideas ?
 

GSDer

Well-known member
Jan 30, 2011
8,469
15
0
Visit site
Welcome to the forums!
I have put the phone into download mode and tried the firmware upgrade and initialsation and I get a message saying this device cannot be updated.
Sounds like you must have a GT-i9300 - apparently Kies doesn't handle this feature like it does on other models.

You can try using a tool called Odin (just Google it - look for v3.07; find a source on XDA) to reload the firmware, which you can find here - mouse-over the region codes to find your country/carrier and download the latest version.

I don't remember if the firmware overwrites the /efs partition, so if that doesn't fix the problem you may have to try something like http://forum.xda-developers.com/gal...ol-updated-08-12-13-efs-professional-t1308546 - I haven't used it myself so I can't provide any support but I'm sure you can find help over on XDA.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
 

Tech_Analysis1

New member
Jun 30, 2014
3
0
0
Visit site
Many thanks for this reply. I can however access the SD card from the Recovery Console. Is there a file I can download to run the recovery from the SD card ?
 

GSDer

Well-known member
Jan 30, 2011
8,469
15
0
Visit site
Is there a file I can download to run the recovery from the SD card ?
I don't think any of the files I pointed out will load using the stock recovery software.
You may be able to find one in your device-specific sub-forum, but you're really better off using Odin.
Or you could try a local carrier store.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
 

Robert Ward6

New member
Jul 2, 2014
2
0
0
Visit site
Hi there,

I have the same problem I think. When I turn on my Galaxy S3 it does not boot past the Samsung Logo. I have pulled the battery on several occasions. This does not work.

I then try to boot into the recovery console and have a few options that dont resolve my issue. However in the recovery mode I see the error "E: failed to mount /efs (invalid argument)"

I have put the phone into download mode and tried the firmware upgrade and initialsation and I get a message saying this device cannot be updated.

Any ideas ?

Hi there,

i have identical problem to you.

Did you find a solution?
 

Tech_Analysis1

New member
Jun 30, 2014
3
0
0
Visit site
Hi there,

I have tried to download the stock firmware but it times out. I try another mirror and I get redirected to a page that seems to be just prompting me to download spam. Is there any advice you can give me to work around this ?

Also when I do download the stock firmware is there a guide as to how I use ODIN ?

Welcome to the forums!Sounds like you must have a GT-i9300 - apparently Kies doesn't handle this feature like it does on other models.

You can try using a tool called Odin (just Google it - look for v3.07; find a source on XDA) to reload the firmware, which you can find here - mouse-over the region codes to find your country/carrier and download the latest version.

I don't remember if the firmware overwrites the /efs partition, so if that doesn't fix the problem you may have to try something like [TOOL] Updated! 26/06/14 - EFS Professional v2.1.73 - Also for NON-Samsung devices! - xda-developers - I haven't used it myself so I can't provide any support but I'm sure you can find help over on XDA.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
 

GSDer

Well-known member
Jan 30, 2011
8,469
15
0
Visit site
I have tried to download the stock firmware but it times out.
You can look on SamMobile.com - you'll have to register to be able to download though.
Also when I do download the stock firmware is there a guide as to how I use ODIN ?
You can find instructions here.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
 

nur ismail

New member
Sep 7, 2014
1
0
0
Visit site
Hello everyone,

I have a similar problem. My phone GT-I9300 is stuck on the boot procedure, and then it continousliy reboots.
If I enter the recovery menu it says: failed to mount /efs (invalid argument)

I never installed other firmware on my phone.. therefore I am surprised that this happened..
I followed different posts on this problem.. many of which suggested to use KIES to install a fimware update.. however KIES does not work in my case..it says: this version cannot be updated!

Then I used ODIN3 to flash a stock firmware obtained from samsung-updates
I still get the same problem..
the phone gets stuck while booting if I install: firmware version 4.3 (2013)
it continously reboots if I install firmware version 4.1.2 (august 2013)
it continously reboots (and there is now way to turn it off except removing battery) with firmware 4.1.1 (october 2012)

I still have 1 year warrenty.. I hope.. so I'll try to bring it to the repair shop. Unless you guys have a better idea?

Thanks!
 

GSDer

Well-known member
Jan 30, 2011
8,469
15
0
Visit site
Welcome to the forums!
Then I used ODIN3 to flash a stock firmware obtained from samsung-updates
I still get the same problem.
Unfortunately, flashing firmware does not touch the /efs partition. If your phone is still under warranty then your best bet is to take it in for service - a Samsung Service Centre should be able to nuke the whole system and rewrite everything.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
 

Sharad Shukla

New member
Oct 5, 2014
1
0
0
Visit site
I have same problem like "failed to mount /efs" flashing stock rom cant solve problem.
my fault only that did not backed it up.so I m going to servicer center. I learned lesson by this that before doing anything like flash new rom u should atleast back up yout efs. cause u can get stock rom from website but not efs settting that is unique for every android phone.:p
 

Barton09

New member
Oct 13, 2014
1
0
0
Visit site
Im getting the same error and my phone isnt connecting to the pc it just there connecting and nothing happening. I got the error message saying to restart the device. Im really lost at this point.
 

GSDer

Well-known member
Jan 30, 2011
8,469
15
0
Visit site
Welcome to the forums!
Im getting the same error
As noted in post #51 there's not a user solution for this problem - reloading the firmware will not correct a corrupted /efs partition. Your best bet is to take it to a Samsung Service Centre (or someplace like Best Buy) to see if they can nuke the whole system and rewrite everything correctly.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
 

ckparungao

New member
Nov 4, 2014
1
0
0
Visit site
Hi! I am having the same problem with my GT-I9300 S3 phone. I already restore back the stock firmware but the phone stucked at SAMSUNG logo and blue light is ON. Please help! Thank you.
 

GSDer

Well-known member
Jan 30, 2011
8,469
15
0
Visit site
Hello and welcome to the forums!
I am having the same problem
You're having which 'same' problem - the /efs error during boot, or the phone getting stuck during the boot?
Did you use Odin to reload the stock firmware? If so, do you have a copy of the log?
Have you tried wiping the system cache in Recovery mode?
 

Samuel Carmack

New member
Feb 27, 2015
2
0
0
Visit site
I tried using the second option on Kies tools and put in the model and IMEI. Kies said that initializing is not supported on that device. Does that mean I need to take it to best buy? Thanks
 

nethenz

New member
Apr 11, 2015
1
0
0
Visit site
Hi there! I tried to follow ur instructions but unfortunately, my device can't seem to connect to kies. Do you know why? I hope you can help me as I have the same problem. Thank you so much.
 

greyserf

Active member
Apr 13, 2013
28
0
0
Visit site
I am having this same issue and have tried the steps above. Everything works until it tries to load the files onto my phone and I get an error message saying:


The PC Failed to recognise the mobile phone.

Any suggestions on how to get past this?
 
Last edited:

Latest posts

Trending Posts

Forum statistics

Threads
946,026
Messages
6,926,211
Members
3,160,050
Latest member
chrshea