SMS says I have a new message, but I do not?

GSDer

Well-known member
Jan 30, 2011
8,469
15
0
Visit site
Welcome to the forums!
I have a HTC One X and there is not an a badge provider app.
Perhaps you should try the HTC One X forums? You're likely to get more accurate information there.

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
 

LylLala

New member
Nov 4, 2014
1
0
0
Visit site
Thank you so much for your help. This helped me resolve this issue. Sad thing is I had called At&t and they couldn't even help me.. :)
 
Jul 29, 2015
1
0
0
Visit site
I had the same problem, and finally figured out how to get rid of it-I had to go into the Hangouts app, click on the left top where the 3 lines are and click on "Archived". I had blocked Twitter notifications in my Hangouts, but they still came in and went straight to the Archives. That's where the unread message was. Once I opened it, the notification went away. On another note, what good is blocking something if you're still going to get messages that won't go away until you open it anyhow? :-\
 

Footysandy

New member
Aug 6, 2015
1
0
0
Visit site
i downloaded and app called Reset Unread Sms. Once installed it asks you to make it the default sms app, thats ok. Once its done checking for unread/phantom texts, it asks you if you want to make messaging your default text message app again. It said that it hadn't found any unread messages for me, but when I closed it and checked my phone again, the incorrect new messages count had disappeared. Yay, I'd tried almost all of the other suggestions here. Awesome app!!!
 

Laurie Miller

New member
Mar 4, 2014
3
0
0
Visit site
Sharp Aquos - SMS says I have a new message but I do not

I have a Sharp Aquos, I had the same problem showing 1 new text message but nothing showed up when I clicked on messages. I found a solution that worked for my phone without resetting it.
1. Go into Settings, wireless and networks.
2. Click on Default SMS app, messaging.
3. Should give you 2 choices, Hangouts or Messaging. Switch to Hangouts, then go back to your icon for messaging and it will open your messages in Hangouts, there I saw the 1 new message.. Delete it, then go back into settings and put your default back to Messaging.. This fixed my problem right away.. I'm sure other phones have a similar set up so you can probably do the same thing. Hope this helps!! :)
 
Last edited:

Laurie Miller

New member
Mar 4, 2014
3
0
0
Visit site
I believe you should be able to do the same thing i did on my phone to fix the problem. You need to change your Default SMS app, in your settings... Look in there and see if you have more than one choice to use.... Thanks
 

Galaxy2124

New member
Sep 10, 2015
1
0
0
Visit site
Thank you sooooo much, Footysandy. That worked perfectly, and I had tried several other things. I was really surprised when it worked!! What a relief!
 

abdulmannan

New member
Aug 27, 2015
3
0
0
Visit site
MR. REHMAN NOOR,
DOWNLOAD ANY SMS APP (OTHER THANK BUILT IN).
THAN SET IT DEFAULT SMS APP.
IT WILL RESOLVE UR ISSUE INSHA ALLAH
(AS I LEARNT FROM Laurie Miller).
 

Trending Posts

Forum statistics

Threads
946,025
Messages
6,926,206
Members
3,160,050
Latest member
chrshea