SMS says I have a new message, but I do not?

sridharkp

New member
Oct 20, 2015
1
0
0
Visit site
I tried all the things above non of them worked for me,
Download sms backup and restore app from playstore
Take the backup all the sms once downloaded, it will get stored in sd card or phone memory as you choose the path
Delete all the messages from your phone
Go back to app and click on restore messages

It worked for me successfully
 

Calhoun420

New member
Jan 30, 2016
1
0
0
Visit site
HEY!!! I had this issue. NO badgefinder, nothing worked. I shut down everything. Nothing. FINALY, download SMS go, send message to yourself, then delete. Only thing that worked.
 

JustinTawney

New member
Oct 2, 2016
1
0
0
Visit site
I tried everything in this thread and nothing worked. Now I was tinkering with the settings and options in my messaging app and found a solution. This may not work for everyone or be the cure all solution to the problem everyone is facing, but I would give it a try.
1. Go to your messaging app
2. Go to options at the top with the three bars
3. Go to block and check if there are any unread messages there
I found that I had blocked somebody and not opened their message before doing so. The message got saved under block so all I had to do was open it and boom the notification went away. Hope this works for some of you!
 
Last edited:

Anthoney 57

New member
Sep 15, 2017
1
0
0
Visit site
I stumbled on the answer: I had deleted a text before I opened it. So it stays as a new message. I hadn't heard from her for a while. Then the she contacted me and when I open the new text...it went away.
 

R C5

New member
Feb 6, 2018
2
0
0
Visit site
Had that problem with my S8. Solved: hold down icon until menu Window pops up. One of the choices should be clear badges. Select and exit. Should be gone.
 

daileighnovember

New member
Aug 2, 2018
1
0
0
Visit site
I juat read some of these answers then went thru my settings and message stuff again. I ad never clicked on emergency alerts before, i had an amber alert apparently in there. Deleted it and immediately the 1 went away!
 

Just Bcause

New member
Dec 20, 2019
1
0
0
Visit site
The stock launcher has badge notifications like that? I wasn't aware. Or are you using the plug in for nova out apex? That's what I'm using for apex. And I'm using Handcent so I don't think I can help. Maybe clear cache?

Go into your sms app,as if to send a msg
Tap the 3 vertical dots at top of screen
Tap " mark all as read"
Issue should be resolved
 
Last edited by a moderator:

AmsoAwesome1

New member
Jul 7, 2020
1
0
0
Visit site
I have had this problem many times before and I have come across two solutions that seem to work every time.

1. Ask your voice assistant “Do I have any unread messages” if your assistant says yes and then reads your “unread” messages you will see that it will not say you have any “unread” messages.

2. Reset your device. This is more of a backup plan. If 1. does not work for you try this.

These are two simple and easy ways to fix a problem like this.
 

Trending Posts

Forum statistics

Threads
946,026
Messages
6,926,214
Members
3,160,050
Latest member
chrshea