1. Murph5150's Avatar
    If I walk into a Starbucks or somewhere else there is public wifi, my phone automatically activates wifi. How do I prevent this from happening?

    Sent from my SCH-I545 using AC Forums mobile app
    08-28-2013 06:10 PM
  2. Bob Schap's Avatar
    do you have a battery saver app? try tweaking the settings. i've been having the same problem and saw that somewhere. will check back here if that doesnt work.
    08-28-2013 06:32 PM
  3. Murph5150's Avatar
    I'm using Battery Guru.

    Sent from my SCH-I545 using AC Forums mobile app
    08-28-2013 07:16 PM
  4. fatboy97's Avatar
    I have no idea what Battery Guru does... so I can not comment to that.

    Under Settings > Wi-Fi > Do you have "Auto-connect" enabled? I prefer turning mine off.
    08-28-2013 07:35 PM
  5. Murph5150's Avatar
    I have auto connect disabled.

    Sent from my SCH-I545 using AC Forums mobile app
    08-28-2013 09:42 PM
  6. STSVA's Avatar
    From the Snapdragon Battery Guru description in the Google Play Store:

    Q. Why is my Wi-Fi ON sometimes, when Im expecting it to be OFF?
    A. Snapdragon BatteryGurus Wi-Fi management feature turns Wi-Fi on when you need it and turns it off when you dont, thereby saving you power. However, even when you dont have Wi-Fi access Snapdragon BatteryGuru will periodically turn Wi-Fi on for few minutes to check if your ability to access Wi-Fi has changed. Likewise when you move to a new location, BatteryGuru will turn Wi-Fi on for a few minutes to check if Wi-Fi access is available. Fear not, turning on the Wi-Fi radio for a few minutes like this has little or no impact on your battery life.
    fatboy97 likes this.
    08-29-2013 08:42 AM
  7. Murph5150's Avatar
    I realize that it doesn't have a significant impact on my battery, but I have to go through the hassle of signing in to the wifi. I get this problem at work. My wifi bars are full but I can't access the Internet. I have to manually turn the wifi off to get back to 4G like 20 times a day. If it's Battery Guru doing this, I'm gonna uninstall the app.

    Sent from my SCH-I545 using AC Forums mobile app
    08-29-2013 03:22 PM
  8. danagin's Avatar
    Here's how I fixed this on mine. I have a Verizon note 3 on straight talk. Once I uninstalled the straight talk account app and the problem went away.

    I messed with all of the wireless and network settings first, nothing changed the issue. Everytime the screen went off, then came back on, it was connecting to wireless.
    04-08-2015 03:59 PM

Similar Threads

  1. Samsung galaxy s4 turns off randomly!!
    By Sanmikele in forum Samsung Galaxy S4
    Replies: 10
    Last Post: 12-17-2016, 04:01 PM
  2. Android 4.3 on SIM free?
    By wanted198 in forum HTC One M7
    Replies: 8
    Last Post: 08-29-2013, 12:50 PM
  3. Android and its connection to other devices
    By olliegab in forum General Help and How To
    Replies: 5
    Last Post: 08-29-2013, 12:41 PM
  4. On my way to pick up my new MAXX!
    By Kaylyn Bayybayy in forum Motorola Droid MAXX
    Replies: 8
    Last Post: 08-29-2013, 12:52 AM
  5. Chromecast for Sale on BestBuy.com
    By mlett in forum Google Chromecast
    Replies: 2
    Last Post: 08-28-2013, 11:01 PM
LINK TO POST COPIED TO CLIPBOARD